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Getting Started with AutoCAD LT 
 

Back in the early 2000s, the following AutoCAD LT techniques were routinely 
required to overcome problems encountered with AutoCAD (DWG/DXF) files and 
maximize the amount of useable CAD data available to AGTEK (with current 
versions of AGTEK, however, these steps are typically no longer needed). 

 
 To start AutoCAD LT, double click its shortcut icon on the 

Windows desktop or click on Start > Programs > AutoCAD LT 
2002 > AutoCAD LT 2002 from the Windows taskbar. 

 
 
 

 

 
 
 

 
 

o By default, the Active Assistance dialog will 
pop up automatically with most program 
functions.  It can be disabled for the current 
session by moving the Windows Arrow cursor 
over the Active Assistance icon on the 
Windows taskbar, Right-clicking, and selecting 
Exit (it can be restored by clicking the Active 
Assistance button at the upper-right of the 
screen). 

 
o The AutoCAD LT Today dialog can be 

permanently disabled by selecting Tools > 
Options from the menu, clicking the System 
tab, and setting Startup to Do not show a 
startup dialog (it can be restored through the 

same procedure). 
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Getting Started with AutoCAD LT (Cont.) 

 
 
This is what the main AutoCAD LT screen looks like as configured 
out-of-the-box . . . 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

Pull-down menus. Pan and zoom 
buttons. 

Layers control 
button. 

Data display area. 

Explode button on 
the toolbar. 

Command line 
where you can 
type Auto CAD 
commands, and 
where program 
prompts are 
displayed. Model tab. Model or 

Paper status. 

Normal AutoCAD 
LT Cross Hair 
cursor. 

Active Assistance 
button. 

X (East) and Y 
(North) coordinates 
of the Cross Hair 
cursor. 

See next page for 
instructions on opening CAD 
files with AutoCAD LT. 
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Message Dialogs when Opening Files 
 
 
To open a file with AutoCAD LT select File > Open from the menu . . . 

 
 

 
 
 
 
 
 
 

 
 
 
 
 
 

 
 

Step 1:  Choose the drive 
location and data folder of the file 
you want to open (if the file was 
e-mailed to you, it may be on 
your local hard drive or a 
network drive depending on 
where it was saved; if you 
received it on a disk or CD, 
choose the corresponding drive 
location). 
 
Step 2:  Identify the file type 
(.DWG or .DXF). 
 
Step 3:  Once the file is located, 
double click it to open it (or click 
it once, and then click on Open). 
 
 
 
 
 
If you get an incompatible 
version message, you are not 
using the latest version of 
AutoCAD LT, you will not be able 
to open the file, and you have 
three choices: 
 
o Make yourself a nuisance to 

the engineer by requesting the 
file be resent in a compatible 
older version—see page 
hb235. 

 
o Upgrade to AutoCAD LT 2013/ 

2014/2015/2016 (or get a free 
copy of DWG TrueView—see 
pages hb23, hb29). 

 
o Send the file to AGTEK 

Support (see page hb187). 
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Message Dialogs when Opening Files (Cont.) 
 
 

 
 
 

 
 
 

 
 

If you are using an older version of 
AutoCAD LT you may get a Proxy 
Information message that indicates 
a newer AutoCAD application is 
missing.  Click OK to continue 
loading the file.  Even though you 
can open this file, some newer  
AutoCAD objects were not 
translatable to the older file format in 
which they were saved.  This is 
another reminder to upgrade to the 
latest version of AutoCAD LT.  (See 
the Note about Object Enablers on 
the next page.) 
 
 
 
 
 
 
 
If you get a font not found dialog, 
just click OK to continue. 
 
 
 
 
 
 
 
 
 
 
 
 
 
If you get a Select Shape File 

dialog, just click Cancel to continue. 
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Message Dialogs when Opening Files (Cont.) 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

If you get a Proxy Information message 
that indicates AecCivilBase as a missing 
application, the file may contain AecCivil 
Contours that require special processing.  
Be sure the Show proxy graphics radio 
button is on, then click OK to continue 
loading the file (see AecCivil Contours on 
page 19). 

Tip:  After any message dialogs have 
displayed and the file has finished 
loading, use the Purge command to 
delete any empty layers from the file.  
To use the command, type Purge at 
the command line and press the Enter 
key.  (Purge will only delete empty 
layers, so you don’t have to worry 
about losing any valuable data.) 

Note: Downloading and installing Autodesk’s free AutoCAD Object Enablers (see page hb23) 
may reduce the occurrence of Proxy Information warnings when opening DWG/DXF files with 
AutoCAD and AutoCAD LT.  Object Enablers can be found on Autodesk’s website but direct links 
are available on the Resources page at www.EarthworkSoftwareServices.com (see page hb29 

of the Day 2 Seminar Handbook). 
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Saving Changes to CAD Files 
 
Most of the troubleshooting techniques in this chapter require changes 
to the CAD file that must be saved before you exit AutoCAD LT.  
Typically, it is better not to save these changes back to the original CAD 
file (if you make a mistake, you may need the original CAD file again).  
The following procedure is a good way to save changes without affecting 
the original file . . . 
 

 
 
 
 
 
 
 
 
 
 

 
 

 

 
 

Step 1:  After completing any 
required modifications (as 
discussed in the following 
sections of this appendix), 
Select File > Save As from the 
menu (File > Export if you are 
using a version earlier than 
AutoCAD LT 2000/2002). 
 
Step 2:  Select a save 
destination (such as 
C:\Agtek\Data). 
 
Step 3:  Name the DXF file. 
 
Step 4:  Select AutoCAD LT 
2010 (or earlier) DXF for the 
file type. 
 
Step 5:  Click on the Tools 
button and select Options. 
 
 
Step 6:  Click the DXF 
Options tab. 
 
Step 7:  Check the Select 
Objects option (don’t change 
the format from ASCII or the 
number of decimal places from 

 

Tip:  These steps will save 
your changes to a DXF file.  If 
you prefer to save your 
changes to a DWG file, you 
can use the WBLOCK 
command and a similar set of 
steps (see your AutoCAD LT 
users guide for details). 
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Saving Changes to CAD Files (Cont.) 
 
 

 
 
 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
Step 8:  Click on Save. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 9:  Window select 
around all visible data 
desired for export by Left-
Clicking once in the upper 
left corner, then once in 
the lower right corner, 
making sure all data is 
completely within the 
selection window. 
 
[If you window select from 
right to left, data partially 
within the selection 
window is also selected.] 
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Saving Changes to CAD Files (Cont.) 
 
 

 
 

 
 

 
 
 

 

 
 
Step 10:  The selected data 
is highlighted and the 
program prompts to select 
more objects.  Right click or 
press Enter to indicate the 
selection is complete. 
 
[Note:  The main advantage 
of using window select in this 
process is to exclude data on 
any frozen layers (see pages 
11-12) and any extraneous 
data that may have 
horizontal coordinates 
considerably different from 
those of the actual data that 
you wish to use.] 
 
 
 
 
 
 
 
 
 
 
 
Step 11:  The export process 
is complete when the blank 
Command prompt returns to 
the lower command line.  
You are done with AutoCAD 
LT, so select File > Exit from 
the menu (DO NOT save the 
file when prompted). 
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Missing Data? 
 
 
Once a file is loaded in AutoCAD LT, compare the screen to the paper 
grading plan.  Sometimes data shown on the paper plan does not appear 
on the screen . . . 
 
 The data may actually be excluded from the file.  It is not uncommon for 

data such as existing ground contours to be contained in a separate 
CAD file.  If you do not already have the separate file containing the 
missing data, you should contact the engineer and request it. 

 
 The data may be part of the current file but it may be in a form that 

AutoCAD LT cannot process and display.  A good example of this is 
proxy information related to AecCivil Contours (see page 19). 

 
 If the screen looks empty, select View > Zoom > Extents from the 

menu, then look carefully for two tiny “specks” on opposite edges of the 
screen (the file may contain two sets of data separated by millions of 
feet on the horizontal and each speck can include huge amounts of 
data).  If you see the specks, zoom in on them for a closer look. 

 
 Finally, the data may be part of the current file but it is on a layer that is 

Off and/or Frozen.  Such data can be identified as follows: 
 
 

       
 
 

 
 
 
 
 

 
Step 1:  Select Format > Layer from the menu 
or click on the Layers button in the upper-left 
corner of the AutoCAD LT screen to access the 
Layer Properties dialog (see next page). 

Layers button 
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Missing Data? (Cont.) 
 
 

 
 
 

 
 

The first column of the Layers 
Properties dialog lists the Name of 
each layer in the file. 
 
The second and third columns 
indicate the On/Off and 
Freeze/Thaw status of each layer.  
To be visible, a layer must be On 
(yellow light bulb) and Thawed 
(yellow sun). 
 
Step 2:  Look at the names of 
layers that are Off (darkened light 
bulb) and/or Frozen (snowflake) to 
identify the layers that may contain 
the missing data (1FTOG, 5FTOG, 
and OGLABELS in this example). 
 
Step 3:  Turn ON the identified 
layers by clicking on their darkened 
light bulbs, and Thaw the identified 
layers by clicking on their 
snowflakes. 
 
Step 4:  Click on OK to regenerate 
the plan view and see the 
previously missing data.  Now that 
you can see the data, you can 
troubleshoot it if necessary. 
 
[Note: The fourth column indicates 
Locked (closed padlock) or 
Unlocked (open padlock) layer 
status.  A Locked layer cannot be 
modified until it is Unlocked.  
Some of the problems described 
next require layers to be modified 
by Exploding them—those layers 
must be unlocked first.  
Incidentally, importing CAD files 
with Blocks (page 14) on Locked 
layers may crash AGTEK--using a 
CAD prgram to Unlock all layers 

will solve the problem.] 
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Paper Space vs. Model Space 
 
There are two primary working environments in AutoCAD: Model 
Space and Paper Space.  Model Space is where drafting and design 
takes place, while Paper Space is where layout for the paper plot 
takes place.  The only problem with Paper Space is that it will not 
allow the selection of individual objects for troubleshooting purposes.  
To avoid this problem, switch to Model Space . . . 
 

 

 
 
 
 
 
 

 

The best way to switch 
from Paper Space to 
Model Space is to click 
the Model tab here. 

You can also click here to 
toggle between Paper 
Space and Model Space.  
[In AutoCAD LT 98 or 
earlier versions, select 
View > Model Space 

[Tiled] from the menu.] 
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Block References 
 

Early versions of AGTEK could not import Block References unless they were 
first exploded . . . 

 

 
 

 

FYI:  A Block is a CAD object that 
contains other CAD objects.  Exploding 
a Block (see next page) frees the 
individual objects within the Block. 
 
Step 1:  Press the Esc key several 
times to clear any previous selection, 
and then click on the object in question 
(any existing contour in this example).  
If each point on the contour is 
highlighted by a small blue square, that 
object is “AGTEK friendly” and it is not 
a Block Reference.  If (as in this 
example) the clicked contour and every 
other contour are highlighted by 
dashed lines, there may be a problem. 
 
Step 2:  Identify the selected object by 
Right-clicking and selecting 
Properties from the pop-up menu (or 
type LIST or LS at the command line). 
 
Step 3:  The Properties dialog indicates 
that the object is a Block Reference. 
 
Step 4:  Close the Properties dialog by 
clicking the X button. 

Note:  AGTEK automatically explodes Block References as the 
CAD file is being read.  To minimize any problems, place all 
related CAD files in the same AGTEK job folder before importing 
them in AGTEK.  Some Block configurations, such as Blocks in 
External Reference files (see page 16), Blocks on Locked layers 
(page 12), or nested Blocks (Blocks within Blocks), can present 
problems.  Troubleshooting steps for Blocks include using a CAD 
program to Unlock layers, explode Blocks (see next page) and 
possibly convert the CAD file to an earlier version file, then re-
import the modified CAD file in AGTEK (DWG TrueView—see 
pages hb23, hb29—can be used for the file conversion but it 
does not include an explode function).  If that fails, send the 
problem CAD file to AGTEK support—see page hb187—or plot 
the CAD file to PDF (with DWG TrueView) and import the 
resulting vector PDF file in AGTEK per the steps starting on page 
hb34—the PDF accuracy will often be very good (see page 
hb22). 
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Block References (Cont.) 
 
 

 
 
 

 
 

 
 
 
 
 
 
Step 5:  Explode the 
selected block by selecting 
Modify > Explode from 
the menu or by clicking on 
the Firecracker toolbar 
button. 
 
Step 6:  Click on a contour 
now (zoomed here) and it 
should highlight with blue 
squares. 
 
[If a block will not explode, 
verify that it is not on a 
Locked layer—see page 
12.  If the layer is not 
locked, try exploding it a 
second time—sometimes 
blocks contain other blocks 
(nested Blocks).] 
 
Step 7:  Right-click and 
select Properties from the 
pop-up menu.  This 
contour is now a 3D 
polyline. 
 
Step 8:  After Exploding 
the block, save your 
modifications per page 8 
and try re-importing it in 
AGTEK. 
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External References 
 
Early versions of AGTEK required the following manipulations for 
External References . . . 

 
 

 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

FYI:  An External Reference (or Xref) links one 
DWG file (the Xref file) to another DWG file (the 
Master or Base file).  The Xref objects are visible in 
the Master/Base file, but the Xref objects are not 
physically in the Master/Base file. 
 
Step 1:  Press the Esc key several times to clear 
any previous selection, and then click on the object 
in question (any existing contour in this example).  
If each point on the contour is highlighted by a 
small blue square, that object is “AGTEK friendly” 
and it is not an External Reference.  If (as in this 
example) the clicked contour and every other 
contour are highlighted by dashed lines, there may 
be a problem. 
 
Step 2:  Identify the selected object by Right-
clicking and selecting Properties from the pop-up 
menu (or type LIST or LS at the command line). 
 
Step 3:  The Properties dialog indicates that the 
object is an External Reference (note the name of 
the External Reference file). 
 
Step 4:  Close the Properties dialog by clicking the 
X button. 
 
[Note: If the files are on a CD/DVD they may need 
to be copied to your hard drive and opened from 
there.  After copying the files, you may also need to 
disable the Read Only attribute—in Windows 
Explorer, Right click the file and select Properties, 
then Uncheck the Read Only attribute and click 
OK.] 
 

Note:  As long as all related CAD files are located in the same AGTEK job folder, 
AGTEK should read most External Reference files without problem; however, 
AGTEK may have problems with External References that contain blocks (see 
page 14) or with other issues (page hb59).  If so, a potential solution is to bind the 
External References and (if necessary) explode the resulting block (see page 15 
above and pages hb236, hb238 for examples) and possibly convert the modified 
file to an earlier version (with a CAD program or with DWG TrueView—see pages 
hb23, hb29), then re-import the modified Base CAD file in AGTEK.  If that fails, 
send the Base and External Reference CAD files to AGTEK support and they will 
fix it for you—see page hb187—or plot the CAD file to PDF (with DWG TrueView, 
hb239) and import the resulting vector PDF file in AGTEK per the steps starting 
on page hb34—the PDF accuracy will normally be very good (see page hb22). 
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External References (Cont.) 
 
 

 
 
 

 
 
 

 
 

 

Step 5:  Select Insert > 
Xref Manager from the 
menu or type XREF at the 
command line. 
 
Step 6:  Check the Status 
of the file name identified 
in Step 3 above.  If it is 
Loaded, you have the file 
and can proceed.  If it is 
Not Found, you do not 
have it and should request 
it from the engineer. 
 
Step 7:  Click on the file 
name (60448SURV in this 
case), and then click on 
Bind. 
 
 
Step 8:  Select the Bind 
option and click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
Step 9:  The file is no 
longer listed in the Xref 
Manager because it is now 
physically part of the 
current file.  Click on OK. 
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External References (Cont.) 
 
 

 
 
 

 
 

Step 10:  Press the Esc key 
several times to clear any previous 
selection, and then click on an 
existing contour.  The clicked 
contour and every other contour 
are again highlighted by turning to 
dashed lines, so there may still be 
a problem. 
 
Step 11:  Identify the selected 
object by Right-clicking and 
selecting Properties from the pop-
up menu (or type LIST or LS at the 
command line). 
 
 
 
 
 
 
 
 
 
Step 12:  The Properties dialog 
indicates that the object is a Block 
Reference. 
 
Step 13:  Explode the block.  
Close the Properties dialog by 
clicking the X button, pick the 
block, and then select Modify > 
Explode from the menu. 
 
Step 14:  After Exploding the block, 
save your modifications per page 8 
and re-import the modified CAD file 
in AGTEK. 
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AecCivil Contours 
 

Various AutoCAD add-on applications can be used by designers to produce site 
grading plans (e.g., Civil 3D).  These add-on applications produce custom CAD 
objects that AutoCAD LT does not recognize and which are replaced by proxy 
graphics when the file is opened.  Depending on how the proxy graphics were 
saved, AGTEK may not be able to read them (always ask the engineer to “enable 
and save proxy graphics” in the furnished CAD files) . . . 

 
 

 
 
 

 
 
 

 
 

Step 1:  In the file open 
dialog, click on the CAD file 
you want to open and take 
note of the Preview image 
(are contours displayed in 
it?).  Click on Open. 
 
 
 
 
 
 
Step 2:  A Proxy Information 
message will be displayed if 
the file contains proxy 
objects; be sure the Show 
proxy graphics option is 
selected, and then click OK. 
 
[The proxy message is the 
first hint that the file may 

contain AecCivil Contours.] 

Tip: Depending on how they are saved in the 
CAD file, AGTEK can read AecCivil contours, 
but it can be helpful to install the free Civil 
Object Enablers for your copy of AutoCAD 
(see Note on page 7).  If you have problems 
with AecCivil contours from any version of 
AutoCAD, you can try using AutoCAD LT to 
perform the steps beginning on this page or 
(better yet) send the CAD file to AGTEK 
Tech Support or ask the designer to convert 
the AecCivil contours to Polylines for you). 
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AecCivil Contours (Cont.) 
 
 

 
 
 

 
 
 
 
 
 
 
 

 

[If a proxy objects message 
was displayed when the file 
was opening but you do not 
see any contours after the 
file is opened (and the 
contours are not on a layer 
that is Off and/or Frozen) 
and/or you see unexpected 
rectangles on the screen, 
you may be unable to use 
the AecCivil Contours in this 
file.  If so, Ask the engineer 
to convert the contours to 
polylines and resend the file 
to you, or send the file to 
AGTEK’s support 
department and they will do 
the conversion for you—see 
pages hb187-188.] 
 
Step 3:  If you see the 
contours after the file is 
opened, click on one 
contour.  If only the clicked 
contour highlights as a 
dashed line (with no blue 
squares), it is probably an 
AecCivil Contour. 
 
Step 4:  With the contour still 
selected, Right-click and 
select Properties from the 
pop-up menu.  The 
Properties dialog confirms 
the proxy status of the 
contour (note the layer name 
for future reference). 
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AecCivil Contours (Cont.) 
 
 

 
 
 

 
 
 
 
 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 5:  Contours are 
normally drafted on two 
layers, one of which is a 
labeled index layer (typically 
the 2-, 5-, or 10-foot 
contours).  So repeat Steps 
3 and 4 above until you have 
identified and checked the 
second contour layer. 
 
[Remember to press Esc 
several times before clicking 
on the next contour.] 
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AecCivil Contours (Cont.) 
 
 
 
 
 
 

 
 
 

 

Step 6:  Select Format > Layer from 
the menu or click on the Layers 
button in the upper-left corner of the 
screen to access the Layer 
Properties dialog. 
 
Step 7:  Click on one of the contour 
layers identified in Steps 3 - 5 above 
(CONT-HGH_1006 in this case), and 
then click on Current. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 8:  Right-click anywhere in the 
white-background area of the dialog 
and select Select all but current 

from the pop-up menu. 

Two layers of proposed contours have been identified as containing AecCivil Contours.  These 
layers will need to be exploded before they can be used in your AGTEK program.  Each contour 
is a separate object so the most efficient means of exploding all the contours on both layers is to 
use a window selection.  But, because we do not want to indiscriminately explode other layers in 
the file, the two contour layers should be isolated first.  This is accomplished by freezing all 
layers but the two of interest … 
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AecCivil Contours (Cont.) 
 
 
 

 
 
 
 

 
 
 

Step 9:  Click on a yellow sun icon in 
the third column of any layer other 
than the one selected in Step 7 
above (if you start by clicking on a 
snowflake, you will have to click it a 
second time). 
 
[This step freezes all layers but the 
current, CONT-HGH_1006, layer.] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 10:  Click on the name of the 
other contour layer identified in Steps 
3 – 5 above (CONT_LOW_1006 in 
this case), and then click on the 
snowflake for that layer to Thaw it.  
Click on OK. 
 
[All layers are now Frozen except for 

the two layers of AecCivil Contours.] 
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AecCivil Contours (Cont.) 
 
 

 

 
 
 
 

 
 
 

 
 
 
 
Step 11:  Window select 
around all visible data by 
clicking once in the upper left 
corner, then once in the 
lower right corner, making 
sure all data is completely 
within the selection window.   
 
[If you window select from 
right to left, data partially 
within the selection window 
is also selected.] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 12:  Explode the 
selected contours by 
selecting Modify > Explode 
from the menu or by clicking 
on the Firecracker button 
here. 
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AecCivil Contours (Cont.) 
 
 

 

 
 
 

 
 
 
 

 
 
 
 
Step 13:  If you pick one of 
the exploded contours it will 
still highlight as a dashed 
line without blue squares.  
And if you check its 
properties it will still indicate 
that it is a proxy entity.  But 
the exploding process has 
modified it so that AGTEK 
can process it. 
 
 
 
 
 
 
 
 
 
 
Step 14:  Use the Layer 
Properties Manager to Thaw 
any of the Frozen layers that 
you need for AGTEK.   
 
[The existing contours in this 
file are actually an External 
Reference that will need to 
be bound, and then 
exploded—see page 16 
above and pages hb236, 
hb238.] 
 
Step 15:  Save your 
modifications per page 8. 
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Files in Architectural Units 
 
 
CAD files for site grading are typically created with decimal drawing 
units (1 CAD unit = 1 foot) but occasionally a grading design will be 
drafted in architectural units (1 CAD unit = 12 inches).  By default, 
AGTEK processes imported CAD data for decimal units so any 
architectural unit CAD data will be processed incorrectly unless you 
know it is in architectural units and compensate for it. 
 
 To determine a file’s Unit Type in AutoCAD LT, open the file and 

select Format > Units from the menu: 

 
 
 

 
 
 
 
 

 
 

o Note the Drawing Units Type 
under Length (in this case, the 
file is in Architectural units 
and steps will need to be taken 
for correct processing in 
AGTEK. 

 

Warning: If you click on the 
display button to the right of 
Architectural, you can select 
Decimal units from the list.  Do 
not do it—it will not correct the 
problem! 
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Files in Architectural Units (Cont.) 
 
 
There are two ways to approach using CAD data in architectural units 
with AGTEK . . . 
 
 The first (and more complicated) approach is to use AutoCAD LT 

to convert the CAD file’s architectural units to decimal units as 
described below: 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

 

Step 1:  Select File > New 
from the menu (or type 
NEW at the command 
prompt and press Enter). 
 
Step 2:  Type a “.” and 
press Enter (to indicate no 
template file). 
 
Step 3:  Select Insert > 
Block from the menu (or 
type DDINSERT at the 
command prompt and 
press Enter). 
 
Step 4:  Click on Browse 
to locate the architectural 
unit CAD file (9waldenC1-
1.dwg in this case). 
 
Step 5:  Complete the rest 
of the Insert dialog 
EXACTLY as shown here, 
and then click OK. 
 
Step 6:  Select View > 
Zoom > Extents from the 
menu. 
 
Step 7:  Correct any other 
problems with the CAD 
file, and then save it by 
selecting File > Save from 
the menu.  This file can 
now be imported by 
AGTEK with no further 
adjustments required. 

Note: A corresponding conversion can 
be made with TurboCAD (see hb240). 
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Files in Architectural Units (Cont.) 
 
 
 The second (and much simpler) approach is to let the AGTEK 

program do the units conversion automatically when it imports and 
transfers the CAD layers as follows (see page hb100 for a more 
detailed example of this method): 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

Step 1:  In AGTEK 3D/4D, 
select File > Open from 
the menu and select the 
architectural unit CAD file. 
 
Step 2:  In the CAD 
Transfer mode BEFORE 
transferring any layers, 
select Data Transfer > 
CAD Transfer Units from 
the menu. 
 
Step 3:  In the CAD 
Transfer Units dialog, 
select Architectural and 
then click OK. 
 
[This setting change will 
only affect the current 
session of AGTEK; the 
next time the program is 
started, the CAD Transfer 
Units will default back to 
Feet (decimal units).] 
 
Step 4:  Begin transferring 
the CAD layers.  The 
AGTEK program will 
automatically compensate 
for the architectural units 
of the CAD data. 

Metric Unit Conversions: Substituting the appropriate scale 
factors, the DDINSERT command described on the previous 
page could be used to convert CAD data from metric units to 
decimal units before importing the CAD data into AGTEK.  But 
a metric-to-decimal units conversion can also be made in 
AGTEK as follows: (1) Import and process the metric CAD data 
with AGTEK (using Meters as the CAD Transfer Units, per 
page hb60) and save the resulting metric AGTEK job file, (3) 
create a new AGTEK job file, selecting Feet for Units in the Job 
Information dialog, (4) import (select File > Import from the 
menu) the metric AGTEK ESW file created in Step 1, (4) in 
CAD Transfer Mode (but before actually transferring any data), 
select Data Transfer > CAD Transfer Units from the menu, 
(5) in the CAD Transfer Units dialog, select Feet and User 
Defined (enter “0.3048” for the Units per Foot value), and click 
OK, and (6) transfer all data to the appropriate surfaces/layers 
and it will be converted to feet.  A very good online video 
documenting these steps is available on AGTEK’s website at 
www.agtek.com/trainingvideos/Earthwork3DMetric.html. 
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CAD Survey Data (Spot Elevations) 
 
Sometimes spot elevations are furnished in a CAD file in lieu of a 
contoured topo (the utility of CAD spot elevations will depend on how 
they are represented in the CAD file) . . . 

 

 
 

 
 
 
 
 
 
 
 
 

 
 

Step 1:  If there are layers containing 
other data in the file, use the Layer 
Properties Manager (as described on 
pages 22-23) to isolate the layer(s) 
containing the spot elevation data. 
 
Step 2:  Identify what types of CAD 
objects represent the survey data (pick 
an object, Right-click, and select 
Properties).  In the best case, each 
survey shot will be a single 3D POINT 
object at the correct horizontal ground 
position.  In the next-best case, each 
survey shot will consist of at least two 
CAD objects: 
 
o A TEXT object (2D) representing 

the elevation value, and 
 
o A POINT object (2D) representing 

the horizontal ground position of 
the shot. 

 
In the worst case, each survey shot will 
be represented by 3 or 4 objects or 
attributes (elevation, point number, 
description, ground position, etc.) 
combined in a Block Reference.  You 
can try exploding the block (see page 
14-15), but some or all of the data may 
disappear and you may have to 
manually digitize the points from the 
paper or PDF plan sheet. 
 
 
 
 
 
 
 
 
 
 
Step 3:  Save any modifications per 
page 8. 

Tip:  If the spot 
elevation ground 
position point is 
represented as a 
“+” or “x” with no 
horizontal 
coordinates at the 
center, use 
AutoCAD LT to 
change the point 
display style (Left 
click on one of the 
ground points, then 
select Format > 
Point Style from 
the menu and 
choose the dot 
option rather than 
“+” or “x”). 

Tip:  If the spot elevations are 
represented in blocks and exploding 
them causes the loss of required data, 
the AutoCAD Burst command can be 
used to convert the attributes to text 
objects.  [Only available in full-blown 
AutoCAD with the Express Tools option.] 


